using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?<!X-MAS\s)TREE\b";
string substitution = @"X-MAS TREE";
string input = @"X-MAS TREE //this sentence should be excluded
BLA BLA TREE //this sentence should be recognized
XMAS TREE
X-MASTREE
X-TREE
X-MASTREE
How to exclude ""X-MAS TREE""?
Because all of those regex, will be replace with ""X-MAS TREE""
If I search with keyword ""TREE"", it will be infinite loop, because ""X-MAS TREE"" has ""TREE""
I tried with this combination, but not working:
\b(XMAS TREE|X\-MASTREE|X\-TREE|TREE|(?!X\-MAS TREE)\b
\b(XMAS TREE|X\-MASTREE|X\-TREE|(?!X\-MAS \s)TREE)\b
\b(XMAS TREE|X\-MASTREE|X\-TREE|((?!X\-MAS )|\w*)TREE)\b
\b(XMAS TREE|X\-MASTREE|X\-TREE|(?:(?!X\-MAS) )TREE)\b";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}