import re
regex = re.compile(r"\b(?<!X-MAS\s)TREE\b")
test_str = ("X-MAS TREE //this sentence should be excluded\n"
"BLA BLA TREE //this sentence should be recognized\n"
"XMAS TREE\n"
"X-MASTREE\n"
"X-TREE\n"
"X-MASTREE\n\n"
"How to exclude \"X-MAS TREE\"?\n"
"Because all of those regex, will be replace with \"X-MAS TREE\"\n"
"If I search with keyword \"TREE\", it will be infinite loop, because \"X-MAS TREE\" has \"TREE\"\n\n"
"I tried with this combination, but not working:\n"
"\\b(XMAS TREE|X\\-MASTREE|X\\-TREE|TREE|(?!X\\-MAS TREE)\\b\n"
"\\b(XMAS TREE|X\\-MASTREE|X\\-TREE|(?!X\\-MAS \\s)TREE)\\b\n"
"\\b(XMAS TREE|X\\-MASTREE|X\\-TREE|((?!X\\-MAS )|\\w*)TREE)\\b\n"
"\\b(XMAS TREE|X\\-MASTREE|X\\-TREE|(?:(?!X\\-MAS) )TREE)\\b")
subst = "X-MAS TREE"
result = regex.sub(subst, test_str)
if result:
print(result)