import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?<!X-MAS\\s)TREE\\b";
final String string = "X-MAS TREE //this sentence should be excluded\n"
+ "BLA BLA TREE //this sentence should be recognized\n"
+ "XMAS TREE\n"
+ "X-MASTREE\n"
+ "X-TREE\n"
+ "X-MASTREE\n\n"
+ "How to exclude \"X-MAS TREE\"?\n"
+ "Because all of those regex, will be replace with \"X-MAS TREE\"\n"
+ "If I search with keyword \"TREE\", it will be infinite loop, because \"X-MAS TREE\" has \"TREE\"\n\n"
+ "I tried with this combination, but not working:\n"
+ "\\b(XMAS TREE|X\\-MASTREE|X\\-TREE|TREE|(?!X\\-MAS TREE)\\b\n"
+ "\\b(XMAS TREE|X\\-MASTREE|X\\-TREE|(?!X\\-MAS \\s)TREE)\\b\n"
+ "\\b(XMAS TREE|X\\-MASTREE|X\\-TREE|((?!X\\-MAS )|\\w*)TREE)\\b\n"
+ "\\b(XMAS TREE|X\\-MASTREE|X\\-TREE|(?:(?!X\\-MAS) )TREE)\\b";
final String subst = "X-MAS TREE";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}