use strict;
my $str = 'X-MAS TREE //this sentence should be excluded
BLA BLA TREE //this sentence should be recognized
XMAS TREE
X-MASTREE
X-TREE
X-MASTREE
How to exclude "X-MAS TREE"?
Because all of those regex, will be replace with "X-MAS TREE"
If I search with keyword "TREE", it will be infinite loop, because "X-MAS TREE" has "TREE"
I tried with this combination, but not working:
\\b(XMAS TREE|X\\-MASTREE|X\\-TREE|TREE|(?!X\\-MAS TREE)\\b
\\b(XMAS TREE|X\\-MASTREE|X\\-TREE|(?!X\\-MAS \\s)TREE)\\b
\\b(XMAS TREE|X\\-MASTREE|X\\-TREE|((?!X\\-MAS )|\\w*)TREE)\\b
\\b(XMAS TREE|X\\-MASTREE|X\\-TREE|(?:(?!X\\-MAS) )TREE)\\b';
my $regex = qr/\b(?<!X-MAS\s)TREE\b/p;
my $subst = 'X-MAS TREE';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";