using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<[^>]+\sid\b[^>]*>";
string input = @"<name attribute=value attribute=""value"" id='value'>CDAT! dfg abc=""ddd"" <name attribute=value attribute=""value"" id='value'>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}