$re = '/<[^>]+\sid\b[^>]*>/m';
$str = '<name attribute=value attribute="value" id=\'value\'>CDAT! dfg abc="ddd" <name attribute=value attribute="value" id=\'value\'>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);