// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<[^>]+\sid\b[^>]*>").unwrap();
let string = "<name attribute=value attribute=\"value\" id='value'>CDAT! dfg abc=\"ddd\" <name attribute=value attribute=\"value\" id='value'>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}