package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<[^>]+\sid\b[^>]*>`)
var str = `<name attribute=value attribute="value" id='value'>CDAT! dfg abc="ddd" <name attribute=value attribute="value" id='value'>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}