$re = '~<[^<]*(?<!\/(src))>(*SKIP)(*F)|([\w\.\'\-\+]+\@(?:[a-z0-9\.\-\p{L}]+\.)+(?:[a-zA-Z0-9\-\p{L}]{2,24}))~iu';
$str = 'test@домен.ком
test@domain.com
γλώσσα@τομέας.com
<p>info@example.com</p>
<img src="images/svg/ff_logo_hex@1x.svg" alt="formfranska" width="130" />
<picture>
<source media="(min-width: 38em)" srcset="ff_logo_hex@1x.jpg">
<source srcset="ff_logo_hex@1x.jpg">
<img src="ff_logo_hex@1x.jpg" alt="">
</picture>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);