import re
regex = re.compile(r"<[^<]*(?<!\/(src))>(*SKIP)(*F)|([\w\.\'\-\+]+\@(?:[a-z0-9\.\-\p{L}]+\.)+(?:[a-zA-Z0-9\-\p{L}]{2,24}))", flags=re.IGNORECASE | re.UNICODE)
test_str = ("test@домен.ком\n"
"test@domain.com\n"
"γλώσσα@τομέας.com\n"
"<p>info@example.com</p>\n"
"<img src=\"images/svg/ff_logo_hex@1x.svg\" alt=\"formfranska\" width=\"130\" />\n\n"
"<picture>\n"
" <source media=\"(min-width: 38em)\" srcset=\"ff_logo_hex@1x.jpg\">\n"
" <source srcset=\"ff_logo_hex@1x.jpg\">\n"
" <img src=\"ff_logo_hex@1x.jpg\" alt=\"\">\n"
"</picture>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")