using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"nome:[\s\S]+?(?=e-mail)";
string input = @"Bla bla bla bla bla NOME: JOSH IDNUMBER: 098766 E-MAIL: josh@gmail.com bla bla bla.
Bla bla bla bla bla NOME: JOAO IDNUMBER: 045344 E-MAIL: josh@gmail.com bla bla bla.";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}