use strict;
my $str = 'Bla bla bla bla bla NOME: JOSH IDNUMBER: 098766 E-MAIL: josh@gmail.com bla bla bla.
Bla bla bla bla bla NOME: JOAO IDNUMBER: 045344 E-MAIL: josh@gmail.com bla bla bla.';
my $regex = qr/nome:[\s\S]+?(?=e-mail)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}