re = /nome:[\s\S]+?(?=e-mail)/mi
str = 'Bla bla bla bla bla NOME: JOSH IDNUMBER: 098766 E-MAIL: josh@gmail.com bla bla bla.
Bla bla bla bla bla NOME: JOAO IDNUMBER: 045344 E-MAIL: josh@gmail.com bla bla bla.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end