#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\(\d{4}\)\.\s).+?(?=\,\s\d)"
Local $sString = "Супонина, А.Т., Петров, Б.А. (2021). Политическая мораль современной российской молодежи: ценности, представления, установки. Научный результат. Общество: политика, экономика, право, 3 (92), 19–22." & @CRLF & _
"Шестопал, Е.Б., Рогач, Н.Н. (2020). Идеальные представления как фактор восприятия реального политического лидера. Полис. Политические исследования, 4, 166–180. DOI: 10.17976/jpps/2020.04.12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")