use strict;
my $str = 'Супонина, А.Т., Петров, Б.А. (2021). Политическая мораль современной российской молодежи: ценности, представления, установки. Научный результат. Общество: политика, экономика, право, 3 (92), 19–22.
Шестопал, Е.Б., Рогач, Н.Н. (2020). Идеальные представления как фактор восприятия реального политического лидера. Полис. Политические исследования, 4, 166–180. DOI: 10.17976/jpps/2020.04.12';
my $regex = qr/(?<=\(\d{4}\)\.\s).+?(?=\,\s\d)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}