import re
regex = re.compile(r"(?<=\(\d{4}\)\.\s).+?(?=\,\s\d)", flags=re.MULTILINE)
test_str = ("Супонина, А.Т., Петров, Б.А. (2021). Политическая мораль современной российской молодежи: ценности, представления, установки. Научный результат. Общество: политика, экономика, право, 3 (92), 19–22.\n"
"Шестопал, Е.Б., Рогач, Н.Н. (2020). Идеальные представления как фактор восприятия реального политического лидера. Полис. Политические исследования, 4, 166–180. DOI: 10.17976/jpps/2020.04.12")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")