$re = '/(?<=\(\d{4}\)\.\s).+?(?=\,\s\d)/m';
$str = 'Супонина, А.Т., Петров, Б.А. (2021). Политическая мораль современной российской молодежи: ценности, представления, установки. Научный результат. Общество: политика, экономика, право, 3 (92), 19–22.
Шестопал, Е.Б., Рогач, Н.Н. (2020). Идеальные представления как фактор восприятия реального политического лидера. Полис. Политические исследования, 4, 166–180. DOI: 10.17976/jpps/2020.04.12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);