#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z](?=(?:[a-z]*\d){0,4}(?![a-z]*\d))(?=[a-z\d]{3,11}$)[a-z\d]+$"
Local $sString = "a1a2a3a4aaaa" & @CRLF & _
"a3333aaaaaaa" & @CRLF & _
"a1a2a3aaaaa2" & @CRLF & _
"a1a2a3" & @CRLF & _
"a222" & @CRLF & _
"aaaa" & @CRLF & _
"a2aa" & @CRLF & _
"f2fdfgdd" & @CRLF & _
"w333rrrrrrr4" & @CRLF & _
"rrrrrrrr4444" & @CRLF & _
"r22rrrrrrrrr" & @CRLF & _
"g4fff333ffff" & @CRLF & _
"" & @CRLF & _
"333333333333" & @CRLF & _
"1111" & @CRLF & _
"1aaa" & @CRLF & _
"1aaaaaaaaaaa" & @CRLF & _
"1a2aaaaaaaaa" & @CRLF & _
"a1aaaaaaaaaaa" & @CRLF & _
"a11111aaaaaa" & @CRLF & _
"a122a3aaaaa2" & @CRLF & _
"a1a2a3a4a5aa" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")