import Foundation
let pattern = #"^[a-z](?=(?:[a-z]*\d){0,4}(?![a-z]*\d))(?=[a-z\d]{3,11}$)[a-z\d]+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
a1a2a3a4aaaa
a3333aaaaaaa
a1a2a3aaaaa2
a1a2a3
a222
aaaa
a2aa
f2fdfgdd
w333rrrrrrr4
rrrrrrrr4444
r22rrrrrrrrr
g4fff333ffff
333333333333
1111
1aaa
1aaaaaaaaaaa
1a2aaaaaaaaa
a1aaaaaaaaaaa
a11111aaaaaa
a122a3aaaaa2
a1a2a3a4a5aa
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)