using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z](?=(?:[a-z]*\d){0,4}(?![a-z]*\d))(?=[a-z\d]{3,11}$)[a-z\d]+$";
string input = @"a1a2a3a4aaaa
a3333aaaaaaa
a1a2a3aaaaa2
a1a2a3
a222
aaaa
a2aa
f2fdfgdd
w333rrrrrrr4
rrrrrrrr4444
r22rrrrrrrrr
g4fff333ffff
333333333333
1111
1aaa
1aaaaaaaaaaa
1a2aaaaaaaaa
a1aaaaaaaaaaa
a11111aaaaaa
a122a3aaaaa2
a1a2a3a4a5aa
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}