import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z](?=(?:[a-z]*\\d){0,4}(?![a-z]*\\d))(?=[a-z\\d]{3,11}$)[a-z\\d]+$";
final String string = "a1a2a3a4aaaa\n"
+ "a3333aaaaaaa\n"
+ "a1a2a3aaaaa2\n"
+ "a1a2a3\n"
+ "a222\n"
+ "aaaa\n"
+ "a2aa\n"
+ "f2fdfgdd\n"
+ "w333rrrrrrr4\n"
+ "rrrrrrrr4444\n"
+ "r22rrrrrrrrr\n"
+ "g4fff333ffff\n\n"
+ "333333333333\n"
+ "1111\n"
+ "1aaa\n"
+ "1aaaaaaaaaaa\n"
+ "1a2aaaaaaaaa\n"
+ "a1aaaaaaaaaaa\n"
+ "a11111aaaaaa\n"
+ "a122a3aaaaa2\n"
+ "a1a2a3a4a5aa\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}