#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?=(?P<group1>(\b\w+(\W+\w+\b){0,3})))((?P=group1)(\W+|$)){2}"
Local $sString = "word word word" & @CRLF & _
"word1 word2 word1 word2" & @CRLF & _
"word1 word2 word3 word1 word2 word3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")