using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(?P<group1>(\b\w+(\W+\w+\b){0,3})))((?P=group1)(\W+|$)){2}";
string input = @"word word word
word1 word2 word1 word2
word1 word2 word3 word1 word2 word3";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}