import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=(?P<group1>(\\b\\w+(\\W+\\w+\\b){0,3})))((?P=group1)(\\W+|$)){2}";
final String string = "word word word\n"
+ "word1 word2 word1 word2\n"
+ "word1 word2 word3 word1 word2 word3";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}