$re = '/(?=(?P<group1>(\b\w+(\W+\w+\b){0,3})))((?P=group1)(\W+|$)){2}/im';
$str = 'word word word
word1 word2 word1 word2
word1 word2 word3 word1 word2 word3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);