using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)(?:(?!\b(?:at|on|in|adjoining)\b)[^\n\d])*? street\b";
string input = @"flat 14, 24-34 barrington street, London
23 the honourable lord barrington's street, London
23 the honourable lord barrington's street, 42 the dishonarable baron lordington's street, London
land to the south of barrington street, London
plot 12 on barrington street, London";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}