re = /(?<!\S)(?:(?!\b(?:at|on|in|adjoining)\b)[^\n\d])*? street\b/m
str = 'flat 14, 24-34 barrington street, London
23 the honourable lord barrington\'s street, London
23 the honourable lord barrington\'s street, 42 the dishonarable baron lordington\'s street, London
land to the south of barrington street, London
plot 12 on barrington street, London'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end