const regex = new RegExp('(?<!\\S)(?:(?!\\b(?:at|on|in|adjoining)\\b)[^\\n\\d])*? street\\b', 'gm')
const str = `flat 14, 24-34 barrington street, London
23 the honourable lord barrington's street, London
23 the honourable lord barrington's street, 42 the dishonarable baron lordington's street, London
land to the south of barrington street, London
plot 12 on barrington street, London`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}