$re = '/(?<!\S)(?:(?!\b(?:at|on|in|adjoining)\b)[^\n\d])*? street\b/m';
$str = 'flat 14, 24-34 barrington street, London
23 the honourable lord barrington\'s street, London
23 the honourable lord barrington\'s street, 42 the dishonarable baron lordington\'s street, London
land to the south of barrington street, London
plot 12 on barrington street, London';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);