using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/_TESTSUITE\/TESTS\/([a-z0-9][a-z0-9\-]*.[a-z0-9][a-z0-9\-]*_[A-Z0-9][A-Z0-9_\-]*)\/(.*\.fmp4)\/(.*)";
string substitution = @"/rewrite_fmp4.php?url=/usr/local/rtharness/php/_TESTSUITE/TESTS/$1/$2/$3;";
string input = @"/_TESTSUITE/TESTS/org.hbbtv_ADINS025/index.php?url=Video_live/media.fmp4/video/init.mp4";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}