$re = '/^\/_TESTSUITE\/TESTS\/([a-z0-9][a-z0-9\-]*.[a-z0-9][a-z0-9\-]*_[A-Z0-9][A-Z0-9_\-]*)\/(.*\.fmp4)\/(.*)/';
$str = '/_TESTSUITE/TESTS/org.hbbtv_ADINS025/index.php?url=Video_live/media.fmp4/video/init.mp4';
$subst = "/rewrite_fmp4.php?url=/usr/local/rtharness/php/_TESTSUITE/TESTS/$1/$2/$3;";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;