const regex = /^\/_TESTSUITE\/TESTS\/([a-z0-9][a-z0-9\-]*.[a-z0-9][a-z0-9\-]*_[A-Z0-9][A-Z0-9_\-]*)\/(.*\.fmp4)\/(.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/_TESTSUITE\\\/TESTS\\\/([a-z0-9][a-z0-9\\-]*.[a-z0-9][a-z0-9\\-]*_[A-Z0-9][A-Z0-9_\\-]*)\\\/(.*\\.fmp4)\\\/(.*)', 'g')
const str = `/_TESTSUITE/TESTS/org.hbbtv_ADINS025/index.php?url=Video_live/media.fmp4/video/init.mp4`;
const subst = `/rewrite_fmp4.php?url=/usr/local/rtharness/php/_TESTSUITE/TESTS/$1/$2/$3;`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);