using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<)\s*(\/?)\s*([^<>]*\S)\s*(>)";
string substitution = @"$1$2$3$4";
string input = @"< div class='test' >1 > 0 is < b >true< / b> and apples >>> bananas< / div >";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}