use strict;
my $str = '< div class=\'test\' >1 > 0 is < b >true< / b> and apples >>> bananas< / div >';
my $regex = qr/(<)\s*(\/?)\s*([^<>]*\S)\s*(>)/mp;
my $subst = '$1$2$3$4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";