re = /(<)\s*(\/?)\s*([^<>]*\S)\s*(>)/m
str = '< div class=\'test\' >1 > 0 is < b >true< / b> and apples >>> bananas< / div >'
subst = '$1$2$3$4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result