$re = '/https:\/\/kiusk\.ca\/wp-content\/uploads.*\.(?:gif|jpeg|png|psd|bmp|tiff|tiff|jp2|iff|vnd\.microsoft\.icon|xbm|vnd\.wap\.wbmp|webp|)/m';
$str = 'https://kiusk.ca/wp-content/uploads/2022/01/dc2.webp';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);