using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"cat\d\/([a-z]+\d)\/$";
string input = @"site.ru/cat1/cat2/cat3/prod1/
site.ru/cat1/cat2/prod2/
site.ru/cat1/prod3/
site.ru/cat1/telephone3/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}