$re = '/cat\d\/([a-z]+\d)\/$/m';
$str = 'site.ru/cat1/cat2/cat3/prod1/
site.ru/cat1/cat2/prod2/
site.ru/cat1/prod3/
site.ru/cat1/telephone3/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);