import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "cat\\d\\/([a-z]+\\d)\\/$";
final String string = "site.ru/cat1/cat2/cat3/prod1/\n"
+ "site.ru/cat1/cat2/prod2/\n"
+ "site.ru/cat1/prod3/\n"
+ "site.ru/cat1/telephone3/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}