import re
regex = re.compile(r"cat\d\/([a-z]+\d)\/$", flags=re.MULTILINE)
test_str = ("site.ru/cat1/cat2/cat3/prod1/\n"
"site.ru/cat1/cat2/prod2/\n"
"site.ru/cat1/prod3/\n"
"site.ru/cat1/telephone3/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")