# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?sx)
(?|
0(?=.*(0))
|1(?=.*(1))
|2(?=.*(2))
|3(?=.*(3))
|4(?=.*(4))
|5(?=.*(5))
|6(?=.*(6))
|7(?=.*(7))
|8(?=.*(8))
|9(?=.*(9))
)/\1/gsx;t' <<< "0 zero
1 ichi
2 ni
3 san
4 shi
5 go
6 roku
7 shichi
8 hachi
9 kyuu
0123456789"