// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?sx)(?sx)
(?|
0(?=.*(0))
|1(?=.*(1))
|2(?=.*(2))
|3(?=.*(3))
|4(?=.*(4))
|5(?=.*(5))
|6(?=.*(6))
|7(?=.*(7))
|8(?=.*(8))
|9(?=.*(9))
)").unwrap();
let string = "0 zero
1 ichi
2 ni
3 san
4 shi
5 go
6 roku
7 shichi
8 hachi
9 kyuu
0123456789";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}