package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sx)(?sx)
(?|
0(?=.*(0))
|1(?=.*(1))
|2(?=.*(2))
|3(?=.*(3))
|4(?=.*(4))
|5(?=.*(5))
|6(?=.*(6))
|7(?=.*(7))
|8(?=.*(8))
|9(?=.*(9))
)`)
var str = `0 zero
1 ichi
2 ni
3 san
4 shi
5 go
6 roku
7 shichi
8 hachi
9 kyuu
0123456789`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}