import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?sx)\n"
+ "(?|\n"
+ "0(?=.*(0))\n"
+ "|1(?=.*(1))\n"
+ "|2(?=.*(2))\n"
+ "|3(?=.*(3))\n"
+ "|4(?=.*(4))\n"
+ "|5(?=.*(5))\n"
+ "|6(?=.*(6))\n"
+ "|7(?=.*(7))\n"
+ "|8(?=.*(8))\n"
+ "|9(?=.*(9))\n"
+ ")";
final String string = "0 zero \n"
+ "1 ichi \n"
+ "2 ni \n"
+ "3 san \n"
+ "4 shi \n"
+ "5 go\n"
+ "6 roku\n"
+ "7 shichi\n"
+ "8 hachi\n"
+ "9 kyuu\n"
+ "0123456789";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}