import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?ms)^\\d{2}/\\d{2}/\\d{4}\\s[\\S\\s]*\\s\\p{Lu}{3}$";
final String string = "\"−−DATE−− ECOA KOB MEMBER−NO\n\n"
+ " 07/22/20 B QM 02004946 NOVUS HOME MORTGAGE TRU\n\n\n"
+ " 06/05/20 B BO 04134811 GS BANK TRU\n\n\n"
+ " 04/24/20 B VF 1916799 US SM BUS ADMIN ODA XPN\n\n\n"
+ " PAGE 3 ( 3 of 9 ) APPLICANT\n\n"
+ "NAME: LARRY OLIVER\n"
+ "S.S.N : 305−02−5380 Date Received: 07/22/20\"\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}