const regex = new RegExp('(?ms)^\\d{2}/\\d{2}/\\d{4}\\s[\\S\\s]*\\s\\p{Lu}{3}$', 'gm')
const str = `"−−DATE−− ECOA KOB MEMBER−NO
07/22/20 B QM 02004946 NOVUS HOME MORTGAGE TRU
06/05/20 B BO 04134811 GS BANK TRU
04/24/20 B VF 1916799 US SM BUS ADMIN ODA XPN
PAGE 3 ( 3 of 9 ) APPLICANT
NAME: LARRY OLIVER
S.S.N : 305−02−5380 Date Received: 07/22/20"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}