import Foundation
let pattern = #"(?ms)^\d{2}/\d{2}/\d{4}\s[\S\s]*\s\p{Lu}{3}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"−−DATE−− ECOA KOB MEMBER−NO
07/22/20 B QM 02004946 NOVUS HOME MORTGAGE TRU
06/05/20 B BO 04134811 GS BANK TRU
04/24/20 B VF 1916799 US SM BUS ADMIN ODA XPN
PAGE 3 ( 3 of 9 ) APPLICANT
NAME: LARRY OLIVER
S.S.N : 305−02−5380 Date Received: 07/22/20"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)