re = /(?ms)^\d{2}\/\d{2}\/\d{4}\s[\S\s]*\s\p{Lu}{3}$/m
str = '"−−DATE−− ECOA KOB MEMBER−NO
07/22/20 B QM 02004946 NOVUS HOME MORTGAGE TRU
06/05/20 B BO 04134811 GS BANK TRU
04/24/20 B VF 1916799 US SM BUS ADMIN ODA XPN
PAGE 3 ( 3 of 9 ) APPLICANT
NAME: LARRY OLIVER
S.S.N : 305−02−5380 Date Received: 07/22/20"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end