package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s\S+\.com\s`)
var str = `текст текст site.com текст
`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}