$re = '/\s\S+\.com\s/m';
$str = 'текст текст site.com текст
';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;